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During the 2014 RHIC run, two electron lenses, designed for electron-proton beam-beam head-on 

compensation [1], were installed and commissioned with the electron beam. They also provided the 

electron beam for some experiments via colliding with the ion- and the 3He- beam [2].  

In this paper, we introduce the RHIC electron lenses and detail their operation.  

 

Figure 1: The layout of RHIC electron lenses 

I. Introduction to RHIC electron lens system 
 

A. The sub-system of the electron lens 
 

1. Electron gun and collector 

To generate an electron beam for head-on beam-beam compensation with a proton beam, the 

electron lens needs a source of an electron beam and a beam dump. Figure 2, depicts an electron 

gun [3, 4] acting as a source of an electron beam, along with a collector [3, 4], serving as a dump. 

The electron beam is propagated from the electron gun to the collector. During the middle of 

electron beam trajectory, there is a straight section for electron-proton interactions.  



 

Figure 2: Electron gun and collector 

The electron gun has a cathode and an anode. When there is electrostatic field between them, and 

the cathode is heated up, an electron beam emerges from the cathode. A modulator, with three 

power supplies, provides an electrostatic field between the cathode and anode [5, 6]. The three 

power supplies are shown in Figure 3. They represent one charge power supply, one discharge 

power supply, and an anode bias power supply. The polarity (+/- sign) of the power supplies in 

Figure 3 shows that the charge and discharge power supplies provide positive voltage on the 

anode; and the anode bias power supply provides negative voltage on the anode, all with respect 

to the cathode. The negative anode bias voltage prevents the emission of the electron beam when 

there is no trigger for it. Inside the collector, there is an electron reflector and also an ion 

collector  

2. High voltage power supplies 

Although an electron beam can be produced from the electrostatic field between the cathode and 

anode, it cannot be propagated further from the electron gun to the collector without several 

other high voltage power supplies. These are the cathode bias, the collector and the reflector 

power supplies and they are also depicted in Figure 3.  



 

Figure 3: High voltage power supplies for the electron lens 

The power supply for the cathode bias provides a negative potential with respect to ground for all 

other power supplies; accordingly, it is possible to maintain the energy or the velocity of the 

electron beam via the difference in potential between the cathode bias and the drift tube or the 

vacuum chamber. We can estimate the energy of the electron beam from the potential difference 

between the cathode bias and ground, without considering the effect of space charge.  

The collector power supply provides the collector with a positive potential with respect to the 

cathode bias power supply. The final energy of the beam on the collector is determined by the 

potential difference between the collector and cathode; this energy affects the total power of the 

electron beam on the collector itself. 

The reflector power supply provides negative voltage, with respect to the cathode, for the 

reflector, which diverts the electron beam towards the inner surface of the collector [5].  

3. Magnets of Electron lens 



These strategically positioned high voltage fields cause the electrons to accelerate and propagate 

from the electron gun side to the collector side. However, a group of magnets is needed to 

control the electron beam trajectory. This group of magnets is comprised of six warm solenoids 

[7, 8], and one cold superconducting magnet [9, 10], depicted in Figure 4. Four warm 

(GSX/GSY, CSX/CSY) and two cold correctors coils (SLCX/SLCY) control the beam position. 

 

Figure 4: The warm- and cold-magnets 

4. Instrumentation 

There is an array of instruments provided for the electron beam diagnostics [11]. For measuring 

the electron-beam current, each electron lens has a FCT (Fast Current Transformer) for use in 

pulsed beam mode and a DCCT (DC Current Transformer) for use in CW mode [12, 13, 14] both 

on the gun and the collector side (Figure 5). Each pair of Current Transformer measurements 

(gun side & collector side) can be compared so as to detect the loss of beam in the transport.  

There are two BPMs for measuring the beam position that can be used for the electron beam, as 

well as RHIC beams. Their position measurements can be employed in the preliminary 

alignment of these two beams.  



The electron-backscattered detector [15, 16] on the gun side is dedicated for aligning the electron 

beam and the RHIC beam, and provides the signal for the Lisa application [StartUp->RHIC 

application] in IP10. A simulation routine is available to practice aligning the two beams using 

feedback from this detector. A description and link to the Excel based simulation file is located 

on the Instrumentation Wiki for eLens under 2.3.3 Alignment Simulation [17].  

  

 

 

Figure 5: Instrumentation for the electron lens 

For measuring the electron beam profile, there are two insertion devices. Each electron lens has 

one YAG screen [6] with a camera system, and also a pinhole detector system [6]. Whenever an 

electron beam is present, both detectors are extracted, except when one wants to measure the 

beam profile. In this case, the electron lens is operated with low average beam power.  

There are also four scrapers [6] near the collector entrance that monitor the passage of the 

electron beam into the collector. Figure 6 shows a drawing of the YAG screen, the pinhole 

detector, and the scrapers. The figure also depicts the four quadrants of the scrapers. These 

http://www.cadops.bnl.gov/Instrumentation/InstWiki/index.php/Electron_Lens,_Instrumentation%23Alignment_Simulation


scraper plated pick up small signals induced by the passing electron beam. They are also used to 

measure larger signals when portions of the electron beam is scrapped off during beam steering. 

 

Figure 6: YAG screen, pinhole scanner, and scrapers 

5. Drift tube system 

When the electron lens runs with a high current (1A) electron beam, ions may accumulate in the 

interraction region within the superconducting solenoid. A biased drift tube system with a high 

voltage gradient is used to extract the accumulated ions from the interaction region and sweep 

them into the ion collector, which is shown in Figure 7.  

To extract the ions, a negative voltage must to be applied to these drift tubes. The power supplies 

of the drift tubes are grounded; thus, a negative voltage will reduce the difference in potential 

between the electron beam and the cathode bias. This means that the electron beam will have less 

velocity and a ‘virtual cathode’ may start to affect the beam propagation. When the latter occurs, 

some electrons will be reflected back to the cathode and the electron beam current starts to 

become unstable.  



 

Figure 7: Drift tubes 

Besides ion accumulation, there will be electrons accumulation if the superconducting solenoid 

field is less than 3T. Figure 7 shows that there are two split drift tubes, DT02A and DT02B, that 

are designed for cleaning out these electrons that accumulate because of the magnetic bottle 

effects when the electron lens is running with a low magnetic field (<3T) [18]. 

6. Vacuum system 

Two valves isolate portions of the electron lens vacuum system from the RHIC vacuum system 

via a gun side valve and collector side valve (Fig. 8). The former isolates the electron gun from 

the RHIC vacuum system, while the latter isolates the collector from the same.  

Along with these two valves, there are two cold-cathode vacuum gauges. Another gauge is used 

for monitoring the RHIC vacuum at IP10. All three gauges are frequently used for monitoring 

the vacuum during operation of the electron lens. 

 

Figure 8: Vacuum valves 



 

7. The layout of electron lens and the potential illustration of beam energy 

In Figure 9, we have combined the layout of all individual systems to display the configuration of the 
electron lens.  

 

 

Figure 9: The system layout of the electron lens 

 



 

Figure 10: Illustration of the different potentials in the electron-lens system 

In Figure 10, we can see the electron beam energy change from cathode to collector. 

 

B. The electron lens control software 
 

1. Power supplies PET page 

There is a pet page (pet->RHIC->Systems->ELens->PS->blue or yellow) for controlling most of the 

electron lens power supplies except for the superconducting magnets. Their power supplies are detailed 

in Table 1. 

Table 1: power supplies and names 

Groups Abbreviation Power supply 

Superconducting 
cold magnets 

sms Superconducting main solenoid 

sfs1 Superconducting fringe solenoid 

slcx Long horizontal corrector 

slcy Long vertical corrector 

Warm magnets 
gs1 Gun solenoid one 

cs1 Collector solenoid one 



gsb-csb Bending solenoids 

gs2-cs2 Solenoid two 

gsx gun side horizontal steer 

gsy gun side vertical steer 

csx Collector side horizontal steer 

csy Collector side vertical steer 

Cathode heater gch Cathode heater 

High voltage power 
supplies 

ccv Electron Collector 

cer Electron reflector 

gcb cathode bias 

Modulator power 
supplies 

gam1 Gun anode modulator one 

gam2 Gun anode modulator two 

gab Gun anode bias 

Drift tubes 

dt01 DT01 

dt02a DT02A 

dt02b DT02B 

dt03 DT03 

dt04 DT04 

dt05 DT05 

 

The slew rates for all these power supplies such as the high-voltage power supplies, the 

superconducting magnet, and the warm solenoids are limited so as not to trip off the MPS when the 

readback does not exactly match the setpoint during a value change. Further, all power supplies are 

ramping with 20 Hz for the slew rate from the pet. For example, if we set 0.1 A slew rates for the 

bending solenoid (gsb, csb), the actual ramp rate is 2 A/s. 

For the warm solenoid power supplies and magnets, we have the following configurations: 



o Blue GS1 and yellow GS1 magnets share the same power supply; 

o Blue CS1 and yellow CS1 magnets share the same power supply; 

o Blue/Yellow GS2 and blue/yellow CS2 magnets use the same power supply; 

o Blue/Yellow GSB and blue/yellow CSB magnets use the same power supply; 

 

Figure 11: E-lens warm magnet power supply connection 

Because the blue and yellow GS1/CS1 are connected with same power supply, care should be taken 

when changing them. All eight blue and yellow steer magnet-power supplies only have one ON/OFF 

control button. 

2. Superconducting magnet PET page 

The control of the electron lens superconducting magnet can be obtained from pet->RHIC->Systems-

>ELens->Magnets if the objective is to control magnetic field via current. To manually control these 

power supplies [19], the time in seconds on the control pet page and the current set point must be 

entered. The set point and time will determine the ramp rate. The following ramp rates are the maximum 

for each superconducting magnet: 

Table 2: ramp rates 

Magnet names Max. Ramp Up Rate Max. Ramp Down 
Rate 



SMS (Main Solenoid) 0.2A/s 0.1A/s 

SFS1 (Fringe Solenoid) 0.3A/s 0.3A/s 

SLCX (Long Horizontal Corrector) 0.2A/s 0.2A/s 

SLCY (Long Vertical Corrector) 0.2A/s 0.2A/s 

 

Once the time in seconds and the current set point are entered, the DoIt button must be double-

clicked for the ramp to begin. When manually ramping up the superconducting magnets from zero, it is 

important to first go to a 1 A park level in 30 seconds for main solenoid and fringe solenoid at a 50 

A/step rate. This action prevents the power supply from tripping due to large voltages. Also, the ramping 

procedure requires that the main and the fringe solenoids are ramped alternately in 50 A steps, starting 

with the main solenoid.  

The main solenoid must not exceed the 0.1 A/s ramp rate since it is powered by a unipolar power 

supply; a faster rate will cause the supply to go to a negative voltage so it would no longer be able to 

self-regulate. Ramping down should be done in the same manner as ramping up except for a different 

ramp rate for the main solenoid.  

 Alternate ramping of all the mains together and then all the fringes together is needed. Everything 

should not be ramped at the same time. Also, the ramp should be undertaken in 50 A increments, for 

example, operators should ramp both main solenoid supplies from 50 A to 100 A at 0.2 A/s. When this is 

done, both fringe solenoid supplies should be ramped from 50 A to 100 A at 0.3 A/s.  

Table 3: The example for 3T e-lens superconducting magnets ramp up with full fringe field 

 Magnetic Field PS Current (A) Ramp Time (s) 
1 SMS (B&Y) 1 30 
2 SFS1 (B&Y) 1 30 
3 SMS (B&Y) 51 250 
4 SFS1 (B&Y) 51 167 
5 SMS (B&Y) 101 250 
6 SFS1 (B&Y) 101 167 



7 SMS (B&Y) 151 250 
8 SFS1 (B&Y) 151 167 
9 SMS (B&Y) 201 250 

10 SFS1 (B&Y) 201 167 
11 SMS (B) 212 55 
12 SMS (Y) 234 165 
13 SFS1 (B&Y) 250 167 
14 SFS1 (B&Y) 300 167 
15 SFS1 (B&Y) 350 167 
16 SFS1 (B&Y) 400 167 
17 SFS1 (B&Y) 450 167 
18 SFS1 (B&Y) 470 67 

 

It is very important that the cryo group is consulted before ramping begins to ensure proper helium flows 

rates. The flows are set manually now but will eventually be adjusted automatically. Below is a table with 

the magnetic fields, current levels and flow rates: 

Table 4: Magnetic field, current and flow rate 

E-Lens Blue Main Solenoid 
Magnetic Field PS Current Flow Rate 

1 Tesla 78A .020 g/s 
2 Tesla 156A .022 g/s 
3 Tesla 234A .024 g/s 
4 Tesla 312A .026 g/s 
5 Tesla 390A .029 g/s 
6 Tesla 470A .031 g/s 

 

E-Lens Yellow Main Solenoid 
 Magnetic Field PS Current Flow Rate 

1 Tesla 72A .020 g/s 
2 Tesla 145A .022 g/s 
3 Tesla 213A .024 g/s 
4 Tesla 282A .026 g/s 
5 Tesla 347A .028 g/s 
6 Tesla 424A .030 g/s 

 



The e-lens superconducting magnets can also ramp via tape: ELENS->Systems->PowerSupplies->Cold. 

One can choose the desired magnetic field, however, the tapes here can only ramp up. Another manager 

is under development and can ramp up and down to any magnetic field level from any existing field level.  

If the e-lens cold magnets quench, one can recover using the tape: ELENS->Systems->PowerSupplies-

>Quench->ColdRecovery.tape. 

3. Timing PET page 

This PET page is used to set the operating mode and timing parameters of the electron beam such as: 

pulse length, frequency, and longitudinal position. It also provides timing control for some instruments 

and the modulator. This page can be found under pet->RHIC->Systems->ELens->Timing-

>BlueYellowTime 

For the mode control, the choices are burst mode (single shot), continuous mode (2~200 Hz), FastTest 

mode (200 Hz ~78k Hz), parasitic mode (78k Hz), and DC mode (2~200 Hz). After choosing a mode, it 

must be alive before the mode starts to work. For the burst mode, even after it is made alive, there is 

still no trigger until one clicks the ‘go’ button. The electron beam is turned OFF via turning the mode to 

OFF mode without making it alive. 

 

Figure 12: Waveform for Burst, Continuous mode 



 

Figure 13: Waveform for Parasitic mode 

 

Figure 14: Waveform for DC mode 

The length of the electron beam pulse is controlled by the discharge width parameter. The position 

control is used for longitudinally aligning RHIC beam bunches for the parasitic mode. When the electron 

lens is running in parasitic mode, the electron beam is in the RHIC beam abort gap, in which case the 

position control is set to 334. To overlap the electron beam with the RHIC beam last bunch, the position 

control should be set to 331; for the last two bunches, the position control should be at 328 and the 

discharge width should be set to 2. 



4. MPS PET page 

The Machine Protection System (MPS) is primarily used to protect the blue and yellow e-lens and does 

not affect the RHIC critical devices and/or the RHIC beams. The PET page for the MPS can be found in 

RHIC>Systems>ELens>MPS. The BlueMPS belongs to the blue e-lens MPS PET page and the YellowMPS 

belongs to the yellow e-lens MPS PET page. The e-lens critical devices that are interlocked by the MPS 

are shown on the PET page highlighted in darker color. These are the MPS outputs. Under every output, 

all the devices/statuses that can interlock the relevant output are listed. These are the MPS inputs. When 

a fault occurs, the device status of that item will change from “OK” to “Fault”, as well as the associated 

output status. Once the fault is cleared by the device, the MPS fault can be cleared by double-clicking the 

Reset button on top of the MPS PET page. The handshake parameter on top is to ensure that the MPS 

page is connected to the MPS hardware and reporting the current status. The Relative Fault Time and 

consequently the Latched Fault Time are to determine which fault occurred first in the event of multiple 

failures.  

5.  Instrumentation 

The RHIC electron lens instrumentation pet page is located under pet->RHIC->Systems->ELens->Inst. It 

includes motion controls for YAG screen, Pinhole detector, and ion collector motion (BeamPickUp) as well 

as the signals from the 4 quadrant scrapers; the camera control for YAG image (Camera); the collector 

temperature-sensor reading (CollectorTemperature); the electron backscattered detector control (eBSD); 

DC electron beam current, and the anode bias voltage measurement (Curr_Volt_Meas). 

One can also use the command: RemoteScope –elens to bring up the scopes for the electron lens. These 

scopes provide the signals for electron beam current measurement, anode voltage measurement, eBSD, 

BPM, drift tube, etc. The Blue & Yellow CT O-Scopes have multiplexed inputs (4 per channel) whose 

control is available in the channel input controls of the RemoteScope –elens (special version for eLens). 

Pet pages can be found here showing the integrated signals from the drift tube beam loss signal outputs 

(DriftTubes); as well as an interface to the electrometer measuring the signal from the ion collector 

(IonCollector).  



Table 5: E-lens CT Scope MUX Channel Assignments 

E-Lens CT Scope MUX Channel Assignments 
Ch1 Ch2 Ch3 Ch4 

Drift Tube 04-1/HF 
R50 

REL Anode Voltage 
Hi-Z 

BPM2's (4)  
 R50 

eBSD PMT signal  
Hi-Z 

eBSD W-Block  
Hi-Z 

eBSD W-Foil  
Hi-Z 

Cathode FCT  
Hi-Z 

Collector FCT  
Hi-Z 

Cathode Voltage  
Hi-Z 

ABS Anode Voltage 
Hi-Z 

Cathode DCCT  
Hi-Z 

Collector DCCT 
 Hi-Z 

Drift Tube 04-1/LF 
R50 

Beam Loss (Shunt) 
Hi-Z 

Anode Current FCT 
Hi-Z 

Gun FCT  
Hi-Z 

 

6. Synoptic display 

There is another high level control application for the RHIC electron lenses called the synoptic display. It 

can be found under StartUp->Start ->Specialist tools->eLensApps->Elens Main Display. It displays most 

of the information on control parameters of the electron lens.  

II. Operation of the RHIC electron lens  
 

A. Turn ON/OFF power supplies and set their initial values 
 

1. Turn ON/OFF cathode heater power supplies (gch) 

o Turn the cathode heater PS from OFF to ON; 

o When turning ON the cathode heater for the first time, refer to ‘vacuum conditioning with 

cathode heater’ (II. B. 1); 

o  The cathode heater tape can be run to bring the cathode heater power supply up: tape-

>ELENS->Systems->PowerSupplies->Cathode->Blue(Yellow)_Cathode_Up.tape; 

o This tape will monitor the vacuum while running; if it is less than 5E-7, it will continue to 

ramp up the supply; 



o Alternatively, the current can be set directly to the set point. The cathode heater will 

ramp up with a 0.1 A/s rate without checking the vacuum. One can do this after 

completing the ‘vacuum conditioning with cathode heater as mentioned in the reference; 

o Set the positive set point for yellow from the tape or pet page; 

o Set the negative (which may help to reduce the current leakage between cathode and 

anode issue) set point for blue from the tape or pet page; 

o The maximum absolute read-back for both blue and yellow are10 A (not the set point nor 

the reference); 

o If the e-beam is not used for more than one day, set both power supply currents to 0 via 

the down tape or from the pet page. 

 

2. Turn ON/OFF warm solenoid power supplies (gs1,cs1,gsb,csb,gs2,cs2,gsx,gsy,csx,and csy) 

o Turn all warm solenoid power supplies from OFF->Stby->ON; 

o Use the tape to bring up their current setup: Tape->ELENS->Systems->PowerSupplies-

>Warm->Blue_Yellow_Up.tape ; 

o Their value in the up tape should be modified if they have new setup values; 

o Ramp them down via: Tape->ELENS->Systems->PowerSupplies->Warm-

>Blue_Yellow_Down.tape. 

 

3. Turn ON anode bias power supply(gab) 

o Turn the gam1 power supply to Stby; 

o Then turn gab to ON and set to -0.5 kV; 

o Anode bias PS should be always ON; 

o If one wants to turn it OFF, turn gam1 to Stby, then turn gab OFF. 

 

4. Turn ON/OFF collector power supply (ccv) 



o Turn the collector PS from OFF->Stdy->ON, then the collector PS will go directly to 

1.5kV ; 

o After that, it can be set to any value less than 10 kV. The nominal voltage is 6 kV; 

o To turn it OFF, set its set point to 1.5 kV (because of power supply itself limit, it is not 

able to set 0 kV); 

o Wait until the read-back is 1.5 kV, and then turn the collector PS from ON->Stby->OFF. 

 

5. Turn ON/OFF reflector (cer) and cathode bias power supplies (gcb) 

o Both can be turned ON directly; 

o Set the reflector set point to 3 kV; 

o Set the cathode bias set point to 6.5 kV for blue and -6.5 kV for yellow. (The different 

polarities may be fixed during the summer of 2014); 

o To turn it OFF, set the set points to 0 and turn them OFF. 

 

6. Turn ON/OFF anode modulator power supplies (gam1 and gam2) 

o Reset MPS from its pet page; 

o Set the gam1 and gam2 set point or reference to 0 kV; 

o Switch the gam1 to Stby; 

o Turn ON the gam1 first; 

o Reset MPS for the second time, and there should be NO faults; 

o Turn ON gam1 for the second time to clear the interlock; 

o Click Unlatch on the pet page to clear the gam2 interlock; 

o To turn them OFF, set them to 0, set gam1 to Stby and then turn it OFF. 

 

7. Turn ON/OFF all high voltage power supplies via tape (ccv, cer, gcb, gam1, gam2, gab) after hi-

pot 



o To turn them ON, use tape->ELENS->Systems->PowerSupplies->HV-

>Blue/Yellow_HV_ON.tape; 

o To turn them OFF, use tape->ELENS->Systems->PowerSupplies->HV-

>Blue/Yellow_HV_OFF.tape. 

 

8. Turn ON/OFF all drift tube power supplies after hi-pot (DT01~05) 

o Whether drift tubes are needed or not is not yet clear; 

o One can turn them ON directly, if needed ; 

o Set a negative value for them: DT01 = -0.4 kV, DT02A=DT02B = -0.6 kV, DT03 = -1 kV, 

DT04 = -1.4 kV, DT05 = -1.8 kV; 

o From DT01 to DT05, the voltage should decrease; 

o These values are just the preliminary ones, and may be changed any time in future.  

 

B. Vacuum conditioning with cathode heater  
 

1. Cathode heater vacuum conditioning 

o Close the gun valve from pet->RHIC->Systems->ELens->Vacuum->Valves; 

o Turn on the cathode heater power supply, increase current in 0.1 A/steps and watch the 

gun side vacuum (pet->RHIC->Systems->ELens->Vacuum->Gauges->BlueandYellow-

>bgun-cc / ygun-cc); 

o With cathode heater current increasing, the vacuum will become worse; 

o If the gun vacuum is better than 8E-8, continue until the read-back from the cathode 

heater supply current is 10 A; 

o After cathode conditioning, the ramping up and down of the cathode heater current can 

be done from the tape. 



C. Hi-potting the e-lens system 
 

1. Hi-pot e-lens system 

o The high voltage power supplies can be hi-pot after hi-potting the whole e-lens system 

with a dedicated hi-pot device; 

o Cathode heater should be turned OFF or set to 0 A before any hi-potting done; 

o If there is RHIC beam, the gun and collector valves should also be closed (pet->RHIC-

>Systems->ELens->Vacuum->Valves->bgun-sv, bcol-sv, ygun-sv, ycol-sv); 

o The power supplies needed for hi-pot are listed below. 

Table 6: The HV PS for hi-pot 

Power supply name Read-back Voltage (kV) 
Collector PS 10 
Reflector PS -8 

Cathode bias PS -10 
DT01 -4 

DT02A -4 
DT02B -4 
DT03 -4 
DT04 -4 
DT05 -4 

 

2. Hi-pot Procedure 

Hi-pot using the following procedure: 

o Set the cathode heater power supply to 0, and turn it OFF; 

o Hi-pot the collector high voltage PS to 10 kV only; 

o Hi-pot the reflector high voltage PS to -6 kV only; 

o Hi-pot the cathode bias high voltage PS to -10 kV only; 

o Hi-pot the cathode bias high voltage to -10 kV, while keeping the collector at 10 kV and 

the reflector at -6 kV; 

o Turn OFF the PS of the collector, reflector, and cathode bias; 



o Start to hi-pot DT01, DT02A, DT02B, DT03, DT04, and DT05; 

o After hi-potting the drift tube, keep them ON, then turn ON all the other high-voltage 

power supplies (listed in Table 5), with the cathode bias being the last one; 

o Turn them all OFF when done. 

 

3. Hi-pot the e-lens system ONLY with high voltage power supplies 

o Watch the gun side and the collector side vacuum (pet->RHIC->Systems->ELens-

>Vacuum->Gauges->BlueandYellow->bcol-cc / ycol-cc), and increase the high voltage 

PS in 0.1 kV/steps. When the vacuum starts to increase, lower the high voltage; 

o The vacuum may spike during the hi-pot, indicating that the first critical voltage has been 

reached; 

o Stop when the critical voltage is reached. After vacuum settles, start at 0 kV and repeat 

the previous step; 

o At the beginning, the step size can be 0.1 kV. Next time, if there is no spike in the 

vacuum, start from 0 kV with 0.2 kV/steps until the voltage is 2 kV lower than the 

previous critical voltage.  

 

4. Hi-pot e-lens system with a magnetic field 

o Turn ON all (except gsx, gsy, csx, csy) warm and cold magnetic fields (pet->RHIC-

>Systems->Elens->PS->Blue/Yellow:sms/sfs1) , and repeat the previous step; 

o Change the magnet currents to different value and hi-pot again, including the 

superconducting magnet (sms only), if possible or if it is needed. 

 

5. Hi-pot the e-lens system with the magnetic field and cathode heater  

o Setup the nominal configuration for all warm solenoids and cold solenoids before hi-

potting with the cathode heater ON; 

o Check that the two vacuum valves (gun and collector side) are open; 



o Check the YAG screen and pinhole detector are OUT, and the ion collector is IN from pet-

>RHIC->Systems->ELens->Inst->BeamPickUp; 

o Turn ON the anode bias PS and set to -1 kV; 

o Set the timing mode (pet->RHIC->Systems->ELens->Timing->BlueAndYellow) to OFF; 

o Set all drift tube PS to 0, set collector = 10 kV, reflector = -3 kV and cathode bias = 0 kV; 

o Carefully, increase the current of the cathode heater to 10 A while monitoring the gun, 

collector, and IP vacuum pressures (pet->RHIC->Systems->ELens->Vacuum->Gauges-

>BlueandYellow->ip10-cc); 

o Slowly increase the cathode bias (read-back) to -9 kV. 

D. Control of the E-beam position  
 

1. Control the trajectory of the electron beam via the collector side steerers (csx, csy) for the first e-
beam propagation (burst mode) 
 

o Set all magnets to their nominal values that were obtained from e-beam simulating and 

tracking in the magnetic field; 

o Check that the YAG screen and pinhole detector are OUT, and the ion collector is IN; 

o Collector = 6 kV, reflector = -3 kV, cathode bias = -6.5 kV; 

o Set gam1 = 0 and gam2 =0; 

o Do not turn ON the drift tube power supplies; 

o Set the timing (pet->RHIC->Systems->ELens->Timing->BlueAndYellow) to OFF; 

o Bring up the scraper scope via the RemoteScope –elens command and choose 

Scraper_Blue or Scraper_Yellow; 

o Go to setup -> Hide Signals Interface, to maximize the view (notice the signal names 

appear in an upper menu bar); 

o The four scraper signals are connected with DC1M coupling; 

o Bring up the CT scope via the RemoteScope –lens command, and choose CT_Blue or 

CT_yellow; 



o Set the CT scope channel 1 to Cathode Voltage [10 V/mV Hi-Z], set CT channel 2 to Rel. 

Anode Voltage [2.5 V/mV Hi-Z], set CT channel 3 to Cathode Current FCT [1A/V Hi-Z], 

and set CT channel 4 to Collector Current FCT [1A/V Hi-Z]; 

o These channels include the calibration and coupling (1 A/V means 1 ampere electron 

beam current for a 1V signal, Hi-Z means DC1M ohm impedance);  

o Bring up the MPS (pet->RHIC->Systems->ELens->MPS->BlueMPS/YellowMPS) pet page; 

o Bring up the gun, collector, and IP vacuum (bgun-cc/ygun-cc, bcol-cc/ycol-cc, ip10-cc) 

Gpm or the pet page; 

o Set gam1 = 2 kV and gam2 = 1.7 kV; 

o Set timing to ‘burst’ mode and make ‘live’; 

o Set the width of the burst mode (electron beam pulse length) = 350 bkts; 

o Adjust the time base of the scope (Scraper and CT scope),if needed; 

o Double click the ‘go’ button on the timing pet page to obtain a one-shot beam; 

o On the CT scope, the e-beam’s waveform should be visible; 

o Overlap channel 3 and channel 4 for both FCTs; they should be identical; 

o ON the scraper scope, one or two of four scrapers may have signals, which indicate that 

the e-beam hits on these scrapers and the beam is off-center; 

o Decrease or increase the CSX and CSY PS currents at 10 A/step, and send one electron 

beam pulse by clicking the ‘go’ button on the timing page for each current step to 

decrease the amplitude of scraper signal until nothing is seen;  

o Increase the CSX current at 10 A/step, deliver another pulse, until a signal on scraper 1, 

scraper 4 or both of them becomes visible; note the maximum CSX current; 

o Decrease the CSX current at 10 A/step, until the signal is seen on scraper 2, scraper 3, or 

both; then note the minimum CSX current; 

o Then, set the e-beam to horizontal center via set GSX = (max+min)/2; 

o Increase the CSY current at 10 A/step, until the signal is visible on scraper 1, scraper 2, 

or both; note the maximum CSY current; 



o Decrease the CSX current in 10 A/step, until the signal is apparent on scraper 3, scraper 

4, or both of them; then note the minimum CSY current; 

o Thereafter, set the e-beam to vertical center via set GSY = (max+min)/2; 

o This procedure can be repeated again with 5 A/step; 

o After finishing, the e-beam should be dumped into the collector from its center. 

 

2. First-time control of beam gun side trajectory with BPMs (continuous mode) 
 

o Optimize the electron beam position for the gun side and interaction region via BPMs and 

GSX/GSY; 

o Adopt the CSX/CSY setup from the previous steps; 

o The other parameters are the same; 

o Set the continuous mode discharge width = 1 bkts; 

o Set the frequency = 2 Hz; 

o Bring up the electron beam BPM Gpm (Gpm->RHIC->Instrumentation->BPM->elens-

>BlueElectronsAvg.mon/YellowElectrons.mon); 

o Set gam1 = 0, and gam2 =0; 

o Set the timing mode to ‘continuous’ and make ‘live’; 

o Set gam1 =2 kV and gam2 =1.7 kV; 

o Slowly increase the frequency to 200 Hz (the maximum frequency for the continuous 

mode is 200 Hz) while monitoring the vacuum pressures (gun, collector and IP );  

o Increase gam1 up to 8 kV slowly and monitor the vacuum pressures. Whenever the 

gam1 voltage changes, gam2 is set to 0.85*gam1 for pulse mode; 

o Ask a BPM expert for help to assure an e-BPM signal when increasing the gam1 voltage; 

o If 200 Hz is not enough to find the BPM signal, change the timing to ‘fast test’ mode (set 

the same beam width or pulse length) and increase the frequency slowly until we have 

an e-bpm signal; 

o Monitor the vacuum pressures while increasing either the frequency or the anode voltage; 



o For the ‘fast test’ mode, the minimum frequency is 200 Hz, and the maximum is 78 kHz; 

o Steer the GSX/GSY at 5 A/step to make the average of two BPM1s and BPM2s close to 0 

(bhx.1 + bhx.2 = 0, bvx.1+bvx.2 = 0); 

o To compensate for the change in position of the gun side, the beam position of the 

collector side also should be followed; this can be done manually;  

o  When changing the GSX/GSY current at 5 A/step, assure that CSX/CSY alsochanges in 

C*5A/steps. C might be -1 or some other value. This step can be calibrated later; 

o Alternatively, turn ON the automatic steer application (StartUp->Start ->Specialist tools-

>eLensApps->Elens PS Steer) that makes CSX/CSY automatically follow the GSX/GSY 

changes; 

o After averaging two e-BPMs read 0, the collector side control with scrapers again can be 

reset; 

o Thereafter, the setup for all warm- and cold-magnets is finished; 

o The horizontal position of the electron beam is also controllable via the GSB magnet. This 

may be used if the GSX current reaches its limit (+/-400A); 

o After this is completed, set the timing mode to OFF and set gam1 = 0 kV and gam2 = 0 

kV; 

o If the e-beam is not run for more than one day, the cathode heater should be set to 0 

via pet or the tape sequence. 

E. Run e-lens with different modes 
 

1. Run continuous the mode and measures the e-beam current for an I-V curve 
 

o Bring up the timing pet page (pet->RHIC->Systems->ELens->Timing->BlueAndYellow); 

o Adopt all changes established for gsx, gxy, csx, and csy;  

o Get all other magnets set up from II. D. 2; 

o Get all high voltage power supplies set up from II. D. 2; 

o Set the frequency to 2 Hz; 



o Set gam1 = 0 and gam2 =0; 

o Choose ‘Continuous’ as the timing mode and click ‘Make live’; 

o Set gam1 =2 kV, and gam2 =1.7 kV; 

o Then set the width of the continuous mode discharge = 350 bkts; 

o Bring up the CT scope via the RemoteScope –lens command, and choose CT_Blue or 

CT_yellow; 

o Set the CT scope’s channel 1 & 2 to OFF; set CT channel 3 to cathode current FCT, and 

set CT channel 4 to Collector Current FCT; 

o Measure and note the e-beam current from channel 3 and 4. Both should be same 

(mV=mA). One may overlay these two channels; 

o Increase gam1 to 12.5 kV with 1 kV steps while keeping gam2 = 0.85 * gam1, then 

measure the electron beam’s current from the scope; 

o Next, set the timing mode to OFF and set gam1 = 0 kV, and gam2 = 0 kV; 

o If e-beam will not be run for more than one day, set the cathode heater to 0 via pet or 

tape. 

 

2. Run parasitic mode 
 

o Set all magnets and HV PS parameters from II. D. 2; 

o Set the width of the timing parasitic mode discharge = 1 bkts; 

o Set gam1 gam2 to 0; 

o Choose ‘Parasitic’ as the timing mode and click ‘Make live’; 

o Set gam1 =2 kV; 

o Thereafter gam1 = 2 kV; then set gam2 =1.7 kV (one also can follow the gam2 = 0.85 

gam1); 

o Monitor the current of the gam2 power supply; it should be less than 20 mA; the gam2 

voltage can be lowered to decrease its current; 



o Assure that the IP vacuum is less than 1E-8 Torr, and the gun and collector vacuum is 

less than 1E-7; 

o Increase the gam1 voltage up to 12.5 kV, and the gam2 voltage should follow up to this 

level with 0.85 ratio between them; 

o The electron beam current can be estimated by measuring the current from the 

continuous mode; 

o After this is done, set the timing mode to OFF and set gam1 = 0 kV and gam2 = 0 kV; 

o If the e-beam will not be run for more than one day, set the cathode heater to 0 via pet 

or the tape. 

 

3. Run DC mode 
 

o For the DC beam, the beam current equals the current from the collector PS; the 

collector current is the most reliable measurement for the DC electron beam; 

o  The DC e-beam current also can be measured using the Remotescope –elens command; 

choose CT_Blue or CT_yellow; set channel 3 and channel 4 to the cathode and collector 

DCCT; 

o The DC current measurement can be found from pet under RHIC->Systems->ELens-

>instrumentation->Curr_Volt_Meas_blue/yellow; 

o Set the width of the DC mode discharge = 1 bkts (DC beam OFF time in the abort gap); 

o Set the frequency = 2 Hz; 

o Set both gam1 and gam2 to 0; 

o Set the cathode bias PS to - 0.5 kV; 

o Increase the cathode bias (gcb) to -6.5 kV, and keep monitoring the vacuum pressures in 

the gun, collector and IP ; the IP vacuum should be less than 1E-8 Torr, while the 

vacuum pressures in the gun and collector should be less than 1E-7; 



o Bring up the collector temperature sensor (eight sensors) Gpm, or plot a new graph from 

pet under RHIC->Systems->ELens->Instrumentation-

>CollectorTemperatures_Blue/Yellow; 

o If one or two of the readings from the temperature sensors are far away from others, a 

slight change in CSX/CSY may make all temperature sensors almost the same. When 

doing this, keep monitoring the vacuum pressures; 

o Choose ‘DC’ as the timing mode and click ‘Make live’; 

o After cathode bias = -6.5 kV, start to increase the gam2 voltage, and keep gam1 = 1.2 * 

gam2; 

o Keep increasing the anode voltage gam1 and gam2 to the current you want; 

o Then, set the timing mode to OFF, and set gam1 = 0 kV and gam2 = 0 kV. 

o If the e-beam may be run for more than one day, set cathode heater to 0 via pet or tape. 

 

F. Align e-beam with RHIC beam 
 

1. Align the e-beam and RHIC beam longitudinally 
 

o Normally, when there is RHIC beam, e-lens electron beam is running within the RHIC 

beam abort gap; 

o Bring up the e-lens timing control pet page, where all mode positions should be 0 bkts 

for the abort gap; 

o Bring up the eBSD signal from Gpm->RHIC->Systems->ELens->Instrumentation->eBSD-

blue/yellow.mon; 

o Make sure the HV for the eBSD is ON from pet->RHIC->Systems->ELens->Inst->eBSD-

blue/Yellow; 

o Run the parasitic mode (II. E. 2) with gam1 = 1 kV, and gam2 = 0.85 kV; 

o Set position to 1, 2 or more, so that the e-beam will cover the last one, two, or more 

RHIC bunches; 



o The eBSD count should increase significantly, if the e-beam and RHIC beam collide; 

o To have more counts from the eBSD, turn up the anode voltage to increase the electron 

beam current. 

2. Align the e-beam and the position of the RHIC beam transversely via BPM 
 

o When there is RHIC beam, write down the position of the RHIC proton/ion beam via 

Gpm->RHIC->Instrumentation->BPM->elens->blueIons.mon or YellowIons.mon, and 

calculate the average of two BPM positions (V and H); 

o When there is no RHIC beam, run the parasitic mode with gam1 = 8kV; 

o Ask a BPM expert to time the BPM again, if necessary; 

o Move the position of the electron beam to the average position of the RHIC beam via 

GSX/GSY with a rate of 5A or less per step; 

o Also assure CSX and CSY follow the changes in the beam trajectoryThis can be done 

manually or automatically by turning ON automatic steer application (StartUp->Start -

>Specialist tools->eLensApps->Elens PS Steer). This application can make CSX/CSY 

follow the changes in GSX/GSY.  

o  

3. Align the e-beam and the angle of the RHIC beam via BPM 
 

o Calculate the difference between the readings of two RHIC proton/ion beam BPMs. 

DFBPM = BPM2 – BPM1 can be used;  

o Use the previous procedure for aligning the transverse position (II.F.2) to find electron 

beam BPM signal (Gpm->RHIC->Instrumentation->BPM->elens-

>BlueElectronsAvg.mon/YellowElectrons.mon) 

o Calculate the difference between two positions of the electron beam via two e-lens BPM1 

and BPM2; 

o Change the e-beam angle via SLCX/SLCY (pet->RHIC->Systems->ELens->magnets) at 

1A/step, and assure that the positions of two different e-lens RHIC beam are the same 

as the two different positions of the e-lens electron beam ; 



o Monitor the three vacuum pressures (gun, collector and IP) and change CSX and CSY, if 

necessary when the electron beam trajectory changes; 

o Keep in mind that the SLCX/SLCY also change the RHIC proton/ion beam’s position and 

angle; 

o Next step is to align position via Lisa application. 

 

4. Align the e-beam and RHIC beam position transversely via Lisa 
 

o Follow the procedure for longitudinal alignment (II. F. 1) to align the e-beam to the last 

RHIC proton/ion bunch; 

o Set to IP10 for normal optimization like the other IPs (Optimize One); 

o Complete the alignment of the transverse position first, and then align the angle and 

another position ; 

o Ask the Lisa expert for help. 

G. Measuring the beam profile 
 

1. Measure e-beam profile via the pinhole detector and CSX/CSY 
 

o Run the pinhole tape sequence from ELENS->Systems->PowerSupplies->Pinhole-

>Blue/Yellow_Pinhole_ON; 

o Wait for the high-voltage PS voltage to settle down; 

o Bring up the application for the Elens Image Processor from StartUp->start->Specialist 

tools->eLens Apps->Elens Blue/Yellow; 

o In the top menu go to Settings->Calibration; choose Pinhole from drop-down menu on 

top left. Click Close at the bottom. 

o Then, go to Settings->Timing and set the low and high current for Horizontal and 

Vertical under Raster Scan Params (bottom right);  

o The low and high current can be the present CSX and CSY -/+ 60 A; 



o For the fast test, the Horizontal and Vertical steps can be 20x20, so that it will take 

20x20/10 seconds to finish one scan. After seeing the pinhole data/image with this fast 

test, change to scans of 80x80 steps or 100x100 steps ; 

o Then ‘Make live’;  

o Set the Timing Mode to ‘Pinhole’ and the Detector Mode to ‘PH’ on the top left of the 

Timing window; 

o Bring up the scraper scope using the Remotescope –elens command; the signal from the 

electron beam will be visible when beam starts scanning; 

o Go to pet->RHIC->Systems->ELens->Instrumentation->BeamPickUp_Blue/Yellow, and 

insert the pinhole detector in by selecting ‘IN’ under PH motion control; 

o After 10 seconds when one sees the Pinhole statue is “inserted”, single click the ‘Start’ 

button on the Timing window, then wait until it finishes; 

o A progress bar just under the ‘Start’ button indicates the percentage of pinhole scan 

completed; 

o After it is finished, click StartUp->start->Specialist tools->eLens Apps->Elens 

Blue/Yellow->Data->Acquire Pinhole Data to retrieve the pinhole data; 

o Go to Setting->Analysis Settings in the Elens Image Processor window, and decrease the 

thickness axis as much as possible by moving the slider; decrease the number of chunks 

to as few as possible; 

o Then go to Operations->Find Center of Gravity; 

o ‘Operations->Determine Axis’ for any arbitrary angle; 

o Then ‘Operations->Obtain Brightness Distributions’ to get the beam’s profile; 

o Save the project under File->Save Project; 

o Extract the pinhole detector from pet->RHIC->sSystems->ELens->Instrumentation-

>BeamPickUp_Blue/Yellow 

o Run the pinhole OFF tape from tape->ELENS->sSystems->PowerSupplies->Pinhole-

>Blue/Yellow_Pinhole_OFF. 



 

2. Measure the e-beam profile with the YAG screen 
 

o Run the YAG on the tape from tape->ELENS->Systems->PowerSupplies->YAG-

>Blue/Yellow_YAG_ON; 

o Wait for the high-voltage PS voltage to settle down; 

o Bring up the application for the Elens Image Processor from StartUp->start->Specialist 

tools->eLens Apps->Elens Blue/Yellow  

o Bring up CCD camera control pet page image viewer via pet->RHIC->Systems->ELens-

>Instrumentation->Camera_blue/yellow; 

o Double click ‘camera pet page’ and image viewer to check the CCD camera is functioning 

properly; 

o If unsatisfactory, seek the aid of an expert on elens instrumentation ; 

o Set the camera trigger mode to the external trigger and the exposure time to 100uS; 

o Set the timing mode to ‘Burst’ on the Timing pet page and click the ‘Go’ button; you will 

see an image; 

o Go to pet->RHIC->Systems->ELens->Instrumentation->BeamPickUp_Blue/Yellow and 

extract the ion collector, insert the YAG screen; 

o Select the ‘Burst’ mode and double-click the ‘Go’ button on the Timing page; a new 

image should appear with the electron beam ON; otherwise double-click ‘Go’ again; 

o Then, go to Data->Take Picture on the Elens Image Processor window to obtain a YAG 

image; 

o Thereafter, save the project under File->Save project; 

o Go to Setting->Analysis Settings on the Elens Image Processor window, and change the 

thickness of the axis and the number of chunks wanted; 

o Then go to Operations->Find Center of Gravity; 

o ‘Operations->Determine Axis’ for an arbitrary angle; 

o Then ‘Operations->Obtain Brightness Distributions’ to get the beam’s profile; 



o Extract the YAG screen from pet->RHIC->Systems->ELens->Instrumentation-

>BeamPickUp_Blue/Yellow 

o Run the YAG OFF tape from tape->ELENS->Systems->PowerSupplies->YAG-

>Blue/Yellow_YAG_OFF. 

H. Trouble shoot via MPS 
 

o At times, faults will occur and these will stop the electron beam via the MPS; 

o Troubleshoot the fault by clicking the link on the MPS pet, if available; 

o Some items have a link that can bring up the pet page for the device at fault; 

o Most power supplies have no such link; therefore, go the RHIC->Systems->ELens->PS-

>Blue/Yellow pet page to check the faults associated with these power supplies; 

o After troubleshooting reset the MPS and start the electron beam again. 

III. Discussion  
 

Most hardware of the electron lens is already commissioned; most of the software and controls are also 

completed. But the software and hardware may be changed in the future.  

The development of electron lens control software is open for any possible suggestions from users. 
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Figure 1: The platform and connection for the RHIC electron lens system  

 
 

 
Figure 2: The layout of the RHIC electron lens vacuum system 



 

Figure 3: The layout of the electron gun, which includes a cathode with a radius of 4.1 mm, an anode, 
and a control electrode. The cathode material is IrCe. The control electrode is designed for controlling 
the beam profile and the current. The electron beam energy will be modulated by the potential of the 

drift tube with respect to the cathode potential.  

 

 

Figure 4: The layout of the electron collector. It includes an electron reflector, collector, ion collector, 
and magnet shielding. The collector has water cooling pipe attached to its outside surface to dissipate 

the heat from electron beam. To monitor temperature, eight temperature sensors are mounted 
outside the collector. They are mounted, with 90 degree intervals, around an axis at two longitudinal 

locations. 

 



 

Figure 5: Schematic of the E-lens anode modulator. The modulator can be operated at four 
modes with 10 kV voltages with potential upgrade to 15 kV. To have a fast rise and falling time, the 
modulator has two BEHLKE fast switches with three power supplies, as shown on the left side of the 

figure. The first- and second-power supply together control the beam quality, such as its rise-time and 
stability. The third power supply provides a -500 V negative voltage to the anode to avoid the dark 

current. 

 

 

Figure 6: The parasitic-mode of the modulator and beam compensation with single proton beam. In 
this mode, the electron beam will be aligned longitudinally in the beam abort gap, then moved 

backward to catch the last proton bunch. 
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